Simple, elegant web design

UPDATE

SlideShowPro Director and PHP

SlideShowPro Director has closed. It’s a shame, it was a great piece of software.

SlideShowPro Director runs on PHP5.4 without errors but requires a small amendment to run on PHP5.6, the last version of PHP I think we can use it on. PHP5.6 stops being developed at the end of 2016 and will no longer receive security updates from the end of 2018. Any installations of SlideShowPro Director will start to throw errors and no longer work once hosts upgrade to PHP7, sometime between the end of this year and the end of 2018 if not sooner.

This fix makes SlideShowPro Director work on PHP5.6. In the SlideShowPro Director folder find:

/app/cake/bootstrap.php

replace line 33:

error_reporting(E_ALL & ~E_DEPRECATED);

with:

if (!defined('E_STRICT')) {
	define('E_STRICT', 2048);
}
error_reporting(E_ALL & ~E_DEPRECATED & ~E_STRICT);

Ref: https://github.com/cakephp/cakephp/commit/a9b5b0ce22e34c82f09b656d12f47515c05ec158